مشكلة في ارسال البريد!

andy.afef

:: عضو جديد ::
إنضم
1 نوفمبر 2012
الرسائل
31
الإعجابات
6
العمر
26
#1
عند ارسال بريد من اتصل بنا يصل البريد بدون مشاكل، لكن البريد الخاص بتأكيد التسجيل او البريد الخاص بالمشاركات الجدبدة لا يصل اطلاقا و يسبب الخطأ التالي:


Error Info
كود:
Zend_Mail_Transport_Exception: Unable to send mail. mail() [<a href='function.mail'>function.mail</a>]: Bad parameters to mail() function, mail not sent. - library/Zend/Mail/Transport/Sendmail.php:137

Stack Trace
كود:
#0 /home/content/64/11220564/html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
#1 /home/content/64/11220564/html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#2 /home/content/64/11220564/html/library/XenForo/Mail.php(177): Zend_Mail->send()
#3 /home/content/64/11220564/html/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
#4 /home/content/64/11220564/html/library/XenForo/Mail.php(204): XenForo_Mail->send('androidway.net@...', 'Test', Array, '', '', '')
#5 /home/content/64/11220564/html/library/XenForo/Model/ThreadWatch.php(242): XenForo_Mail->queue('androidway.net@...', 'Test')
#6 /home/content/64/11220564/html/library/XenForo/DataWriter/DiscussionMessage/Post.php(108): XenForo_Model_ThreadWatch->sendNotificationToWatchUsersOnReply(Array, NULL, Array)
#7 /home/content/64/11220564/html/library/WidgetFramework/Extend/DataWriter/DiscussionMessage/Post.php(4): XenForo_DataWriter_DiscussionMessage_Post->_postSaveAfterTransaction()
#8 /home/content/64/11220564/html/library/XenForo/DataWriter.php(1399): WidgetFramework_Extend_DataWriter_DiscussionMessage_Post->_postSaveAfterTransaction()
#9 /home/content/64/11220564/html/library/XenForo/ControllerPublic/Thread.php(504): XenForo_DataWriter->save()
#10 /home/content/64/11220564/html/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_Thread->actionAddReply()
#11 /home/content/64/11220564/html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#12 /home/content/64/11220564/html/index.php(13): XenForo_FrontController->run()
#13 {main}
Request State
كود:
array(3) {
  ["url"] => string(46) "http://www.androidway.net/threads/95/add-reply"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(8) {
    ["message_html"] => string(17) "<p>تجربة</p>"
    ["_xfRelativeResolver"] => string(37) "http://www.androidway.net/threads/95/"
    ["attachment_hash"] => string(32) "5958ea17b74a16e48b6b96bfd9a3d0d8"
    ["last_date"] => string(10) "1370898584"
    ["_xfToken"] => string(8) "********"
    ["_xfRequestUri"] => string(12) "/threads/95/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}

طبعا الارسال من خوادم SMTP للجيميل او غيرة يعطي خطأ Connection refused
التواصل مع الشركة المستضيفة لم يثمر باي شيئ وكان الرد انهم غير مسؤولين عن الاسكربتات المثبتة على الاستضافة

هل من حل في هذا الخصوص اخواني؟
 

andy.afef

:: عضو جديد ::
إنضم
1 نوفمبر 2012
الرسائل
31
الإعجابات
6
العمر
26
#4
هذا الخطأ بسبب استخدام SMTP

Error Info
كود:
Zend_Mail_Protocol_Exception: Connection refused - library/Zend/Mail/Protocol/Abstract.php:277

Stack Trace
كود:
#0 /home/content/64/11220564/html/library/Zend/Mail/Protocol/Smtp.php(167): Zend_Mail_Protocol_Abstract->_connect('tcp://smtp.gmai...')
#1 /home/content/64/11220564/html/library/Zend/Mail/Transport/Smtp.php(199): Zend_Mail_Protocol_Smtp->connect()
#2 /home/content/64/11220564/html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
#3 /home/content/64/11220564/html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#4 /home/content/64/11220564/html/library/XenForo/Mail.php(177): Zend_Mail->send()
#5 /home/content/64/11220564/html/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
#6 /home/content/64/11220564/html/library/XenForo/ControllerPublic/Misc.php(197): XenForo_Mail->send('andy.afef@gmail...', '', Array, 'andy.afef@gmail...', 'ahmad.afef')
#7 /home/content/64/11220564/html/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_Misc->actionContact()
#8 /home/content/64/11220564/html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#9 /home/content/64/11220564/html/index.php(13): XenForo_FrontController->run()
#10 {main}
Request State

كود:
array(3) {
  ["url"] => string(38) "http://www.androidway.net/misc/contact"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(6) {
    ["subject"] => string(7) "bxnxl'l"
    ["message"] => string(8) "'ljn'lj'"
    ["_xfToken"] => string(8) "********"
    ["_xfRequestUri"] => string(12) "/threads/97/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}
 

andy.afef

:: عضو جديد ::
إنضم
1 نوفمبر 2012
الرسائل
31
الإعجابات
6
العمر
26
#6
أخي الكريم
هل هذا هو رابط موقع ؟
http://www.androidway.net/
نعم اخي هو الرابط لكن تزاعلت مع الاستضافه لاني شاكك ان المشكله منهم وهم ما بدهم حتى يتأكدوا منو
فلغيت الاستضافه وراح انتقل لاستضافه Stable Host او Arvixe خلال اسبوع على الاكثر
اذا في اقتراح بخصوص الاستضافه بتمنى تساعدني فيه و شكرا جزيلا لالكم
 

andy.afef

:: عضو جديد ::
إنضم
1 نوفمبر 2012
الرسائل
31
الإعجابات
6
العمر
26
#7
بحب احكيلكم ان المشكله سببها سيرفرات GoDaddy و المنتدى يعمل بشكل رائع على سيرفرات StableHost ومن دون اي مشكله اطلاقاً

ارجو من المشرف اغلاق الموضوع و شكراً لك اخي الكريم Turkialawlqy على التدخل ومحاولة ايجاد حل